Constant Crashing w/ OSP FrontierSpace1.75

  • I've had, as the title says, constant problems with Frontierspace1.75. I follow the download process to the letter and still have issues. I use a clean Freelancer download each time, apply the SDK1.3 before mod use, install flmm1.3, unzip the FS1.75 obtained from the frontierspace website, and apply the mod. In most cases, the mod will work perfectly at start-up. I can go just about everywhere (I was going to mention Sirroco Station, but noticed it was already discussed and is a specific problem with the mod) and do whatever I can, but during most of my time played, the game will suddenly crash and refuse to work again. If I attempt to reload the game, it will reset and attempt to play the original game, only to crash after the opening logos and movies.

    This sudden crash occurs anywhere throughout the game for me. What is even weirder is that the game runs perfectly on another, completely identical laptop that I am using now. To explain, me and my brother have identical laptops (aside from anti-virus use. I believe this may be the problem but have no way to actually prove it). Both laptops are Windows 7 and use the same mod and Mod Manager. However, I run Kaspersky Anti-Virus and my brother runs Norton Anti-Virus. Both are the current versions. What confuses me is that the one on my brother's laptop runs perfectly. Can anyone please help me understand what could possibly wrong with my game/laptop?

    Edited: Just remembered something else I should mention. If I intentionally close the game and try to reopen it, I face the same issue as the crash. It will attempt to play the original game (with the opening logos and movie) and then close when it reaches the loading screen with the title. I attempted to remedy my issue by never closing the game. When I finished playing, I minimized the game and put my computer in hibernate. It worked...for one day. During my playing today, the game crashed and wasted my several hours poured into the game. Perhaps this sounds crazy, but I did wish to test and see if hibernate could work.

  • Post the error log. It can be found in C:\Users\<YOURPROFILE>\AppData\Local\Freelancer\FLSpew.txt

    Use FLSpit to refine it first, so unneeded entries are removed

  • Alright, well, I went looking around, found that FLspit thing (to tell the truth, took me half an hour just to figure out what you were even talking about. Not a vew tech savvy individual) but don't really know how to use it. I know I downloaded it, since I can see it, but my Spew entry is still massive. Didn't change one bit. Is Spit not working or are there really that many things wrong all at once?

    For reference, I reinstalled FL and did all the steps over again. However, this time I started the game, exited the base, redocked, saved, and exited. From there I tried to reload and it crashed and that's how I got my Spew. Still, how does FLspit actually work? I did read elsewhere its some hidden file that runs automatically, but it really doesn't seem to be the case.

    Sorry if it seems I write a lot, I try to be thorough but in most cases I seem to just be wordy rather than concise.

  • FLSpit just filters out some messages and bits of messages, so we can read the remaining messages more easily.

    Unfortunately most mods are not fixed well enough and there may well be thousands of lines in FLSpit.

    What can cause the crash you describe on startup is old saved game files if they are incompatible with your installed version of Freelancer. This will happen because the saved game files are always generated, and they will have unrecognised equipment in them, for example from a mod, or when you are running a mod and the plain freelancer equipment has been removed from it, or when you are running a different mod. These files are not deleted automatically when you re-install Freelancer. Freelancer always reads them during startup, so this is when that crash should always happen, but crashes can be intermittent sometimes and you may get further into the game before it does crash.

    They are normally found (in XP) in your account's My Documents\My Games\Freelancer\Accts folder - just delete or rename the entire My Games\Freelancer folder and try again.

    See also this post: Clean install CTD on Windows 7

    If that doesn't clear the problem then I think in fact you have pointed out your own cause here, the anti-virus programme being the only difference? There are many problems with almost all modern antivirus progs because they read every file before passing it to the programme that requests it, and this delay is causing various crashes and "disabilities" if we can call them that. SOme players don't have problems, where others with exactly the same antivirus do.

    It should be possible to disable Kaspersky temporarily, I don't have it to advise you how.

    Also you will need to disable Microsoft Security Essentials if you have it on your machine?

    An finally Win 7 uses IPv6 for networking by default, instead of the older IPv4 specification - FL doesn't like IPv6, so you should disable that to see if it is another possible cause. I think there should be a method here, otherwise search on Google for the method.

    I hope one of these is your solution to get you up and running.