Freelancer not connecting to the internet

  • Greetings everyone,

    I reinstalled freelancer recently but I seemed to have encountered a problem, basically my game refuses to access the internet as if something is blocking it. I am aware of the fact that the global servers are down so I tried several methods to connect to a server, tried the workaround mod/patch, the FL direct IP program, xfire, adding the -s line but none of them worked.

    I am running NOD32 and have allowed full access for freelancer to the internet, also allowed access through my windows firewall which is currently disabled and forwarded ports 2300-2400 / 2302-2402 on my router. The problem still remains though.

    Interesting part is when I installed freelancer on my laptop and used the FL direct ip, the server I tried to connect to appeared in my list so problem isn't with my router/connection, but with my PC.

    I think I read somewhere that it is either some file that is blocking freelancer from accessing the internet, or there is some file that is missing and it's required for freelancer to go online.

    I ran out of ideas of what to do, scanned for spyware, cleaned up the disks / registry, but something is still there and its getting on my nerves.

    Any help would be appreciated.


  • Yes I have it installed and activated and it still won't show anything , tried both versions 0.9 and 1.0 . As I said , the problem is something is blocking FL from showing the servers and its not my antivirus/router

  • This is really getting annoying, I searched everywhere for similar problems and no one has encountered this before, usually their problem was the AV but it seems mine is somewhere else .

    Also I tried installing the official patch and the unofficial 1.4 patch but the game version still shows V1.0 , any ideas ?

  • the patch does not change the version number

    to connect to a server you very likely need the gls workaround and open ports (which you have)
    assuming direct x is running correctly the problem can only be that you are getting blocked by installed tools on your pc -> antivir or firewall

  • Ok so I uninstalled my antivirus (windows firewall turned off also) and tried connecting with FLdirect ip to the server, nothing showed up in my LAN/ Internet list , also applied the GLS workaround and tried with the antivirus off and still nothing.

    This is really stupid. Maybe something is up with the game cause when I start it up it won't make NOD ask for permission to access the internet (reinstalled the AV and no rules set yet, so yeah it should)

    P.S. I really appreciate the help

  • Well I uninstalled my antivirus (again) , had windows firewall off and tried running it as administrator (running windows XP) with every option in compatibility mode, thing is my account is the only administrator with full access etc. , although there was another account named Administrator but it needs a password and blank ones aren't allowed it seems, so yeah I guess mine works just as well.

    In any case, something IS blocking my game and its not my router/antivirus and probably not windows firewall either....