3D Card Error

  • I have a 5570 that runs 1gb of DDR3 and it gave me the choice to continue, which I hit yes, and it works fine. Runs at 1280x960 with no hitches.

    The rest of my rigs stats include:

    So that's why I'm curious if your problem might just be a driver issue. All I know is that I downloaded the newest catalyst version which was released the end of March. Sorry can't help you more, but I hope this information may throw you in a better direction. Have you tried disabling UAC / running in Administrator mode?

  • cheers for that alfa astrix, you're on the same version of catalyst control, and the only real difference is you have more memory than my system, otherwise I cannot see whats different(yes you're on windows 7, i'm vista).

    The UAC was part of the original vista problems, which I have turned off anyway. Like i said when I played the game 6 months ago, it was fine, and every other time ive played has been ok. I just cant work out whats suddenly causing the game not to detect my card.

    Benn checking updates for hardware, rolled back CCC to last March(2010) and the version before that, still get the same error, because the game recognises the card, as I got the "freelancer doesnt not recognise your 3d card, do you wish to continue Yes/No, select yes, it moves on, and when it gets to the digital anvil intro starts it comes up with the "freelancer does not detect a 3d capable card" which is a straight ok, loading stops, so it recognises it then says it doesnt detect it!!

    anyway i've attached some screenshots of my system, have a look see if ive missed anything.

  • First, running quad core, I would think you'd do an x64 OS instead of x86, just so it utilizes those cores right. Second, I might have missed this, but have you tried having FL load straight to the menu instead of going threw the intro movies?

  • I have found something on one of the german forums, and with my limited (very) german which i remembered from secondary school and some editional help from a translator, I found someone who had the very same issue as me, tried everything but seems like they didnt find a solution, talked about upgrading OS to see if that helped, but nothing posted after that.

    well I want to thank all the people who responded to try to help out, unfortunately i've still not been able to get freenlancer running, so going to leave it a bit and try again in a month or two, If i find a solution I will post it here, otherwise if anyone does find anything please post it here, i will keep checking. Cheers for all your help(Adoxa & Alfa Asterix especially).

  • lol, it is like that isnt it, i dont think ive ever had to try so many things to try to get 1 game to work, it still bizaare that this has happened all of a sudden, and that there are a bunch of work arounds for this particular error which dont work for my pc so, bah!

    think you've said it all alfa.