FL not starting after installing the mod.

  • This happens to me every time I get into high progress with my mod. Last time it happened I had to start rebuilding my mod from the very beginning. In later times it was just a bug in FLMM 1.31 that I just had to rename the folder. It stopped happening ever since I started using FLMM 1.4, but surprise surprise!

    Since I'm not able to use FLSpit or Spew, I'm asking for your help with it. If I won't find any help, I might consider giving a lucky modder all my files (systems I worked on for hours, models I made, a collection of plugins, etc) because I'm NOT rebuilding it.

  • Spew is a plain text file, how can you not use it? In XP, you can find it at \Documents and Settings\User\Local Settings\Application Data\Freelancer\FLSpew.txt; I think this also works in Vista/7, due to symlinks. FLSpit is just a VBScript, so if it's not working, you could always just hardcode the path into it (I expect the script is working, but it's not finding the file? change SpewFolder).

    As for why FL is not starting, that could be due to a previous save game (including the restart). Clear 'em out (within FLMM, use Tools|Open saved game folder).

  • Thanks for the help guys!

    Well, FLSpit showed something weird:


    ERROR: ArchDB::Get(3028069513) failed

    I understand its some part of the Archive DataBase, but what is the rest?

    EDIT: Appearently those were the savegames. I cleared it up and it all works now, but only without the mod. I'd still like to know what this error means if it could be a critical error in the future.

  • That error message generally means that an object wasnt found. Mostly caused by wrong or leftover references. E.g. when you include an item in a loadout and that item doesnt exist

  • I fixed every possible error of this type, and no effect. Are you sure its right?


    ERROR: ArchDB::Get(3028069513) failed

    Again and again and again... I'm gonna have nightmares...

  • What program should I use for this?

    EDIT: I don't think I need translation, I'm pretty sure it means that the system is mocking me. I checked every possible error and seems like everything is just fine.

  • I cleared all the side warnings and all I have left is this:


    WARNING:General:set_gamma_function() called outside of create_buffers/destroy_buffers
    ERROR: ArchDB::Get(3028069513) failed

    This warning is mostly ignored, but the error (as we already found out) is the critical problem. Maybe you can try to translate it for me?

  • Appearently its way simpler then I thought it would be... I thought the problem was with the ships, but it appeared to be with the weapon goods. Well, thanks a lot for the help!