You are not logged in.

Please register in order to use all features of this site.

Argh

Apprentice

(10)

  • "Argh" started this thread

Date of registration: Sep 5th 2003

Reputation modifier: 9

  • Send private message

member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month

1

Monday, January 31st 2005, 4:26pm

Meph, the planet I sent you used a spherical map. You do not have to use cubemaps- take your sphere into UVMapper and give it a sphere map, and then export the CMP... FL´s planets generally do use cubemaps, but that was just a choice the modelers made- FL supports spherical, cubical and planar mapping.
Signature from »Argh«

Date of registration: Sep 7th 2004

Reputation modifier: 8

  • Send private message

member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month

2

Tuesday, February 1st 2005, 1:04am

Due, thanks. I did not know FL would support spherical maps, since the exporter crashed on na cylindrical, I though it wouldn´t do spherical. Woot, jupiter now is as it should. I will leave the original sph, make it a tad smaller, include a cmp with phantom physics around it for the visual, but do all normal stuff to the sph like atmopshere, the wireframe in the hud etc. by simply making the cmp mesh non-targetable. Still sad I did not manage to make a texture for a sph. Well, I think I can live with that as no one will see the difference actually in the end.
Signature from »Mephistopheles«

Date of registration: Sep 7th 2004

Reputation modifier: 8

  • Send private message

member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month

3

Tuesday, February 1st 2005, 1:36am

*UPDATE! Yay! http://img187.exs.cx/my.php?loc=img187&image=screen378dh.jpg This is it. The first real screenshot of my mod. As you can see, the visual 3db is layed around the physical sphere object (with LOD 0, 1 for the sphere underlying). The visual however is visit = 128 and has the sphere as its parent, so without knowing what´s going on you would think that there is actually a real proper texture to the SPH. which there is not.
Signature from »Mephistopheles«

Argh

Apprentice

(10)

  • "Argh" started this thread

Date of registration: Sep 5th 2003

Reputation modifier: 9

  • Send private message

member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month

4

Tuesday, February 1st 2005, 3:10am

Cool, glad to see that it worked out. I would suggest a larger rez for that texture though- I´ve had no problems with DDS up to 2048/2048, although one must be careful, of course, since at that size it´s eating up &gt; 4MB of texture RAM <img src=smilies/icon_smile.gif width=15 height=15 border=0 align=middle>
Signature from »Argh«

Date of registration: Sep 7th 2004

Reputation modifier: 8

  • Send private message

member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month

5

Tuesday, February 1st 2005, 11:54am

lol, 128MB plain graphics memory I have. <img src=smilies/icon_smile_tongue.gif width=15 height=15 border=0 align=middle> Actually, the problem is the current texture´s size. It is some 1440x720, increasing its size does no increase the resolution at all. I originally tried this on Jupiter because the model I tried from the Solar System mod here had even worse texture put on a SPH with the known problems unsolved. I will use my standard sphere now for all the planets and moons I got textures for (=all planets+all major moons), I can produce the exact scale with MS and FLModelTool for each one so it does fit perfectly, also I found removing the 0, 1 LOD from the physical sphere was the better chocie then, because otherwise the atmosphere wouldn´t be rendered either. Instead, I removed the TXM entries except for the atmosphere, and it works without any flaws now even that I have both SPH and 3DB at exact the same size. <img src=smilies/icon_smile.gif width=15 height=15 border=0 align=middle> I will first put in all planets, if any of the textures is not perfect I can edit them later anytime and import them again, that does not affect UVmaps gladly. <img src=smilies/icon_smile.gif width=15 height=15 border=0 align=middle> Edited by - Mephistopheles on 2/1/2005 2:28:55 PM
Signature from »Mephistopheles«

Social bookmarks

Legend:

Forum contains no new posts
Forum contains new posts
Forum is closed
Forum is an external link