You are not logged in.

Please register in order to use all features of this site.

alfa_astrix

Apprentice

(10)

  • "alfa_astrix" started this thread

Date of registration: May 10th 2005

Reputation modifier: 8

  • Send private message

member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month

1

Wednesday, September 28th 2005, 2:26am

This just came to me, but is this supposed to be in <i>Freelancer General Editing </i> instead of here?

Argh

Apprentice

(10)

Date of registration: Sep 5th 2003

Reputation modifier: 9

  • Send private message

member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month

2

Wednesday, September 28th 2005, 2:34am

Lemme guess. The Type = CRUISER, BATTLESHIP, TRANSPORT, etc. These would all cause the steering to &quot;go beserk&quot;- basically, you have to use either FIGHTER or FREIGHTER... none of the other types work.
Signature from »Argh«

alfa_astrix

Apprentice

(10)

  • "alfa_astrix" started this thread

Date of registration: May 10th 2005

Reputation modifier: 8

  • Send private message

member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month

3

Wednesday, September 28th 2005, 3:24am

1) Thanks, that worked, but 2) The ship still has the effect of &quot;it´s going to blow&quot;. I have the armor set low becuase it´s supposed to be low, but I can´t figure out how to fix that without rasing the armor, which is the last thing I want to do. 3) I wanted to know if I had permission to use your Argh/Chips Open SP Lite, Alternative Version. I forgot to get permission to use this, so now I´m asking.

Argh

Apprentice

(10)

Date of registration: Sep 5th 2003

Reputation modifier: 9

  • Send private message

member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month

4

Wednesday, September 28th 2005, 3:43am

&quot;It´s going to blow&quot; is being triggered by a Fuse that´s being called at the hitpoint level the ship has reached. IOW, either get rid of the Fuse entirely in the shiparch entry, or change the number of hitpoints needed to trigger the event. And yes, by all means use Alternative OpenSP- that´s what it´s for :-) Oh yeah... last thought... um, it sounds like you´re making a FL ship that´s not normally flyable ... flyable. If that´s the case, I strongly suggest using a &quot;clone&quot; version of the ship, implemented via XML/FLMM scripts. See my &quot;clones&quot; in the XML Toolkit Mod, 1.2... Edited by - Argh on 9/28/2005 2:46:33 AM
Signature from »Argh«

alfa_astrix

Apprentice

(10)

  • "alfa_astrix" started this thread

Date of registration: May 10th 2005

Reputation modifier: 8

  • Send private message

member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month

5

Wednesday, September 28th 2005, 4:16am

Actually, I was adding a custom ship from a ship pack, and decided to change a few things, that´s when I started having the problems. Download the &quot;Demo&quot; if you want to call it that, and check it out. all it is is one screwed up ship, an accelerated tradelane, and a almost complete rewright of the rescource.dll (took me 6 weeks to do).

Argh

Apprentice

(10)

Date of registration: Sep 5th 2003

Reputation modifier: 9

  • Send private message

member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month

6

Wednesday, September 28th 2005, 4:32am

Really, you can´t get much easier than the way that ships are added on via the XML/FLMM scripts I did for the Toolkit Mod series. If you´ve never taken a look at the Toolkit, and are planning a major project (which, if you´ve been hacking Resources for six weeks, sounds like the case- I´ll apologise in advance for not sitting down and reading its no-doubt copious contents) ... I would really, really strongly urge you to take a look, before you end up re-inventing the wheel with a lot of things. XML/FLMM is a very powerful tool, and can save you considerable time. And the mod includes a lot of documentation about certain coding issues that is hard to find elsewhere. The scripts include everything a ship needs- Engine, Powerplant, Goods entries... the works. And they´re nicely seperated and commented for ease of editing. So long as your mod contains a copy of Shiparch.ini from the SDK, it´s hard to go wrong.
Signature from »Argh«

alfa_astrix

Apprentice

(10)

  • "alfa_astrix" started this thread

Date of registration: May 10th 2005

Reputation modifier: 8

  • Send private message

member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month

7

Wednesday, September 28th 2005, 10:28pm

I have your 1.2 version, and it´s really nice, and It may just be a personal thing, but I don´t care for the whole xml thing. I mean there´s nothing wrong with it, and of course it would save me time, but, I just like to stick with the hard files. Oh, and when I say that I practicly rewrote the resource.dll, this is what I´ve done: 1) Changed all words that were all caps to normal type. 2) Changed the name of a lot of things to fit to my mod, such as what it says whn activating the cruise. 3) Still working, but changed the name for the weapon calsses. 4) Removed the &quot;System&quot; thing after each system, so the New York System is now just New York. 5) Removed the &quot;Space&quot; names. 6) Changed the Sirius Sector to (I haven´t decided yet). 7) Gave Trent a last name (Mars). 8) Still working, but changed all the neural net logs. That the just of it. I plan to find my notes, and <b>then </b> I can tell you everything I´ve changed. Edited by - alfa_astrix on 9/28/2005 9:37:18 PM

Argh

Apprentice

(10)

Date of registration: Sep 5th 2003

Reputation modifier: 9

  • Send private message

member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month

8

Wednesday, September 28th 2005, 11:31pm

XML´s biggest advantages are the ability to put new DLL entries in with very little pain... and the ability to make certain types of changes over a very wide data-set without destroying the original data.
Signature from »Argh«

alfa_astrix

Apprentice

(10)

  • "alfa_astrix" started this thread

Date of registration: May 10th 2005

Reputation modifier: 8

  • Send private message

member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month

9

Thursday, September 29th 2005, 1:41am

So you´re practicly saying that XML editing has a lot less errors than doing the hard .ini. I´ll have to keep that in mind, thanks. But anywise, I wanted to ask you about your Toolkit 1.3. What changes have/are you making from the Toolkit 1.2. I thought the 1.2 practicly covered everything. I mean, I finally set down and read most of the 1.2, and did learn some things I didn´t know (thanks), but I still thought it practicly covered everything.

Argh

Apprentice

(10)

Date of registration: Sep 5th 2003

Reputation modifier: 9

  • Send private message

member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month

10

Thursday, September 29th 2005, 1:50am

It didn´t even come close to covering <i>everything, </i> although it covers most of the things newbie modders want to do right away. 1.3 will cover beauty enhancements, feature better control over Loadouts, and have reworked Encounter types, among many other things. You can see some of the dev. list stuff in my mini-forum here on TLR.
Signature from »Argh«

alfa_astrix

Apprentice

(10)

  • "alfa_astrix" started this thread

Date of registration: May 10th 2005

Reputation modifier: 8

  • Send private message

member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month

11

Thursday, September 29th 2005, 2:29am

All I know is that it helped me a good bit, and showed me some things that I´ve never seen before. (Sorry for changing the subject so much) Also, how come TLR doesn´t have a forum to editing the .exe, and .dll´s. I mean, we´ve already proven that Microsoft desn´t seem to care with Alchander´s patches, and I´ve got my <A href=´http://files.filefront.com/Accelerated_Tradelane_Mod/;4191384;;/fileinfo.html´ Target=_Blank>Accelerated Tradelane Mod</a>. And as soon as I can, I´m going to do the same for the true speed thing in the .exe, where it shows how fast you´re really going at all times. Edited by - alfa_astrix on 9/29/2005 2:26:54 AM

Argh

Apprentice

(10)

Date of registration: Sep 5th 2003

Reputation modifier: 9

  • Send private message

member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month

12

Thursday, September 29th 2005, 4:47am

Um... I´m not even touching that subject with a ten-foot cattleprod. We´ve all been over the issues a million times here... At any rate, 1.3 will show people how to do a lot of things they haven´t done before, and hopefully improve the overall quality of FL mods. I´m making a few non-minor changes to gameplay again, which I hope will be recieved as well as the previous changes... which have all been subtle (insofar as players are concerned) but pretty important from a game-design standpoint.
Signature from »Argh«

alfa_astrix

Apprentice

(10)

  • "alfa_astrix" started this thread

Date of registration: May 10th 2005

Reputation modifier: 8

  • Send private message

member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month

13

Friday, September 30th 2005, 2:49am

Sorry, I forgot that subject was forbidden. Anywise, I just had one final question about toolkit 1.3, <i>How the hell do you find all this stuff out </i>?

alfa_astrix

Apprentice

(10)

  • "alfa_astrix" started this thread

Date of registration: May 10th 2005

Reputation modifier: 8

  • Send private message

member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month member since 156 month

14

Saturday, October 1st 2005, 4:19am

O.K., now I´be got a new problem. One of my ships (Alliance Transporter) is causing a CTD when I try to go to the ship dealer, and when it goes to enter the atmosphre in cruise. The ship works fine everywhere else as I´ve flown it by setting it as my starting ship. The good file has neen changed to &quot;Vehicles_Goods&quot; in the &quot;Vehicles&quot; for all ships, just to let you know. Everything else is the same. Download a copy from the link above, and see if you can help me. Thanks.

Social bookmarks

Legend:

Forum contains no new posts
Forum contains new posts
Forum is closed
Forum is an external link