You are not logged in.

Ro9ue

Apprentice

(10)

  • "Ro9ue" started this thread

Date of registration: Feb 16th 2004

Reputation modifier: 9

  • Send private message

member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month

1

Wednesday, June 22nd 2005, 1:52pm

Heya, Let me start by saying great job on the newest version <img src=smilies/icon_smile.gif width=15 height=15 border=0 align=middle> I like the setup a lot better than the older ones. However, I do have one problem: I can´t get the scaling to work properly - that is, the way it used to. I guess that this probably has to do with the new &quot;float point&quot; setting (<img src=smilies/icon_smile_question.gif width=15 height=15 border=0 align=middle> er, what exactly that means, I don´t know ... <img src=smilies/icon_smile.gif width=15 height=15 border=0 align=middle>). I typically make models, then merge them with the imported model of the <i>Defender </i>to compare the sizes. Then I just select &quot;1&quot; as my scale-down factor in the exporter. The sizes are just right this way. However, I have had incredibly small .cmps for all the things I have tried for the past 12 hours or so. All of them are smaller than hardpoint boxes in HardCMP. So my question is, how does the scaling slider work? I want to be able to merge a custom file with the models of regular stuff, scale to proper size using comparison that way, and then export with little/no scaling down in my .cmp. Is this possible? Thanks a lot. ________ <i> - Ro9ue </i> ___________________________
Signature from »Ro9ue« ________ - Ro9ue ___________________________

Louva-Deus

Gunnery Sergeant

(10)

Posts: 598

Activitypoints: 3,245

Date of registration: Aug 29th 2003

Reputation modifier: 9

Level: 43 [?]

Experience: 3,322,826

Next Level: 3,609,430

  • Send private message

member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month

2

Wednesday, June 22nd 2005, 9:50pm

I have notified Colin so he should have an answer for you soon. Check out the latest beta´s of the <A href=´http://eoa.seriouszone.com/?page=flsdk´ Target=_Blank>Freelancer S.D.K. 1.5</a> and <A href=´http://eoa.seriouszone.com/?page=flexp´ Target=_Blank>Freelancer Explorer v2.x</a>
Signature from »Louva-Deus« Old dog. New tricks.

Ro9ue

Apprentice

(10)

  • "Ro9ue" started this thread

Date of registration: Feb 16th 2004

Reputation modifier: 9

  • Send private message

member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month

3

Thursday, June 23rd 2005, 2:55am

Thanks <img src=smilies/icon_smile.gif width=15 height=15 border=0 align=middle> I have had a little more success in the past few hours, though I am having to make my stuff and then merge them with the templates/examples that are included, then export the stuff using the example .ces settings -- my own settings don´t work properly. But, the awesome thing is, I have made 5 new cockpits in the past day <img src=smilies/icon_smile_big.gif width=15 height=15 border=0 align=middle> I am presently resizing my first gun, and I´ll be testing that baby in a few mins <img src=smilies/icon_smile.gif width=15 height=15 border=0 align=middle> My goodness, it feels so cool to have custom additions like these -- thanks a lot! Now if I can figure out how exactly scaling works, I´ll be in business. Oh (for Louva or Colin, whoever can answer), and also how the exporter decides which HPs will be appended to which group - is this proximity, or something else? Thanks again. Ah, over all, I think a w00t is in order for 0.3! Nice work <img src=smilies/icon_smile_cool.gif width=15 height=15 border=0 align=middle> ________ <i> - Ro9ue </i> ___________________________
Signature from »Ro9ue« ________ - Ro9ue ___________________________

Ro9ue

Apprentice

(10)

  • "Ro9ue" started this thread

Date of registration: Feb 16th 2004

Reputation modifier: 9

  • Send private message

member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month

4

Thursday, June 23rd 2005, 8:11am

Ok, well, just as a little update, I have a new gun and a new CM dropper working now <img src=smilies/icon_smile.gif width=15 height=15 border=0 align=middle> However, they are visible only in space - I can´t see them when docked or when launching from the planet. I had this same problem before with a new thruster model I made, but then I made it into a .3db, and I don´t have amyproblems with that anymore (always visible now). But I can´t do that with guns - they have to by .cmp files, but mine aren´t visible ... Is there a reason and/or a fix for this? Thanks ________ <i> - Ro9ue </i> ___________________________
Signature from »Ro9ue« ________ - Ro9ue ___________________________

Louva-Deus

Gunnery Sergeant

(10)

Posts: 598

Activitypoints: 3,245

Date of registration: Aug 29th 2003

Reputation modifier: 9

Level: 43 [?]

Experience: 3,322,826

Next Level: 3,609,430

  • Send private message

member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month

5

Thursday, June 23rd 2005, 1:05pm

Did you remember to add your LODranges line in your gun entry? LODranges = 0, 20, 60, 100 Check out the latest beta´s of the <A href=´http://eoa.seriouszone.com/?page=flsdk´ Target=_Blank>Freelancer S.D.K. 1.5</a> and <A href=´http://eoa.seriouszone.com/?page=flexp´ Target=_Blank>Freelancer Explorer v2.x</a>
Signature from »Louva-Deus« Old dog. New tricks.

ColinS

Apprentice

(10)

Date of registration: Jan 10th 2004

Reputation modifier: 9

  • Send private message

member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month

6

Thursday, June 23rd 2005, 6:11pm

The minimum scale value has been set at 0.000001 to match the experimental sur exporter. When exporting at 1:1 scale, set the value in the edit control at 1.0 before saving the settings and exporting. Tested by importing a standard ship, exporting a new cmp file, then importing the model from the new cmp file. The model statistics had the same min &amp; max values.
Signature from »ColinS« ColinS

Ro9ue

Apprentice

(10)

  • "Ro9ue" started this thread

Date of registration: Feb 16th 2004

Reputation modifier: 9

  • Send private message

member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month

7

Thursday, June 23rd 2005, 9:34pm

Ah, okay, thanks for clearing up that. That makes sense now. Oh - okay, duh, the lowest setting (the one I used in 2.1) was 1 - the .000001 threw me for a loop though. Okay, that´s better to know. And about LODs - yes, I have those set. I just replaced the archetype line in the weapon_equip and weapon_good .ini files with the correct directory to my model - didn´t change anything else. What do regular models have to have as a minium LOD - 0, 20, in that range? I just don;´t remember because I´va cahnged all LODs in my mod (all the orig stuff works fine with edited LODs) and can´t remember what the orig min values are. Thanks, and great work again <img src=smilies/icon_smile.gif width=15 height=15 border=0 align=middle> ________ <i> - Ro9ue </i> ___________________________
Signature from »Ro9ue« ________ - Ro9ue ___________________________

Louva-Deus

Gunnery Sergeant

(10)

Posts: 598

Activitypoints: 3,245

Date of registration: Aug 29th 2003

Reputation modifier: 9

Level: 43 [?]

Experience: 3,322,826

Next Level: 3,609,430

  • Send private message

member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month

8

Saturday, June 25th 2005, 8:55pm

My last post was original values.
Signature from »Louva-Deus« Old dog. New tricks.

Ro9ue

Apprentice

(10)

  • "Ro9ue" started this thread

Date of registration: Feb 16th 2004

Reputation modifier: 9

  • Send private message

member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month

9

Thursday, June 30th 2005, 1:28pm

W00t!1 Aha, ok, well I ended up needing to make new LOD meshes for my guns for them to appear properly in the game. I made some lower-poly versions and imported those for my lod1 and lod2 LODs. I didn´t really even need to edit the LOD lines in the weapon_equip.ini or anything - FL took care of it automatically. So now I have my cool new guns up and blazing in-game <img src=smilies/icon_smile_big.gif width=15 height=15 border=0 align=middle> Thanks, guys, for such a great tool! ________ <i> - Ro9ue </i> ___________________________ Edited by - Ro9ue on 6/30/2005 12:30:41 PM
Signature from »Ro9ue« ________ - Ro9ue ___________________________

Louva-Deus

Gunnery Sergeant

(10)

Posts: 598

Activitypoints: 3,245

Date of registration: Aug 29th 2003

Reputation modifier: 9

Level: 43 [?]

Experience: 3,322,826

Next Level: 3,609,430

  • Send private message

member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month

10

Thursday, June 30th 2005, 4:54pm

We aim to please <img src=smilies/icon_smile.gif width=15 height=15 border=0 align=middle>
Signature from »Louva-Deus« Old dog. New tricks.

Ro9ue

Apprentice

(10)

  • "Ro9ue" started this thread

Date of registration: Feb 16th 2004

Reputation modifier: 9

  • Send private message

member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month member since 168 month

11

Saturday, July 2nd 2005, 12:29am

Well, you guys have some pretty accurate aim <img src=smilies/icon_smile_wink.gif width=15 height=15 border=0 align=middle> ________ <i> - Ro9ue </i> ___________________________
Signature from »Ro9ue« ________ - Ro9ue ___________________________

Argh

Apprentice

(10)

Date of registration: Sep 5th 2003

Reputation modifier: 9

  • Send private message

member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month

12

Wednesday, July 13th 2005, 10:20am

Hey guys... I really like what I see here, but... 1. I´d like the Exporter to <i>not weld verts I do not want welded </i>. The old one does this, and it´s terribly annoying, and the new one appears to have the same problem. I know that the FL engine supports unwelded verts- there are hard-edged objects all over the place- so if it´s possible, let´s turn that part of the exporter off. I realize some of it has to do with the MS3D SDK source used. 2. I´d like a step-by-step, &quot;making weapons for dummies&quot; instruction manual. If you´ll write one, Colin, I´ll illustrate it and put it into the Tutorials to replace my current &quot;do it the hard way&quot; version <img src=smilies/icon_smile.gif width=15 height=15 border=0 align=middle>
Signature from »Argh«

Louva-Deus

Gunnery Sergeant

(10)

Posts: 598

Activitypoints: 3,245

Date of registration: Aug 29th 2003

Reputation modifier: 9

Level: 43 [?]

Experience: 3,322,826

Next Level: 3,609,430

  • Send private message

member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month

13

Wednesday, July 13th 2005, 8:15pm

Documentation is in the works but will take some time.
Signature from »Louva-Deus« Old dog. New tricks.

Argh

Apprentice

(10)

Date of registration: Sep 5th 2003

Reputation modifier: 9

  • Send private message

member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month

14

Saturday, October 1st 2005, 10:14pm

I´d like to report what looks like a bug. Very simply, I´ve exported a weapon. This went very straight-forwardly, and the weapon, once hardpointed (I did that in HardCMP) works just fine. All well and good. But... the weapon will not draw correctly in Rooms. Works out in main renderer just fine. My guess is that it´s because instead of being named &quot;whatevernameyoupicked.lod0-112.vms&quot;, it´s just named &quot;whatevernameyoupicked.lod0.vms&quot;. That´s the only difference I can see, at the UTF level, from the weapons I´ve done the hard way... any hints about what´s causing this, and if there are any workarounds, would be much appreciated, because this Exporter really is a lot faster than the old, bad way, and offers me full Material support- something I was really lacking with the older methods.
Signature from »Argh«

Argh

Apprentice

(10)

Date of registration: Sep 5th 2003

Reputation modifier: 9

  • Send private message

member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month member since 180 month

15

Sunday, October 23rd 2005, 3:40am

I´ve tried the sample weapon that came with the Exporter. Same problem- weapon works just fine in-game, doesn´t draw in Rooms... Dunno what´s causing this, but I´ve tried messing with the Extents and other stuff, to no avail. Too goshdarn bad, really- this Exporter is like a dream come true, except for this wee little problem. For now, I´ll stick to the hard way.
Signature from »Argh«

Social bookmarks

Legend:

Forum contains no new posts
Forum contains new posts
Forum is closed
Forum is an external link