You are not logged in.

PolarBear

Gunnery Sergeant

(10)

  • "PolarBear" started this thread
  • Israel

Posts: 574

Activitypoints: 3,435

Date of registration: May 3rd 2011

Reputation modifier: 1

Level: 39 [?]

Experience: 1,595,383

Next Level: 1,757,916

Thanks: 4

  • Send private message

member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month

1

Friday, June 17th 2011, 4:09pm

Homeworld(1)->Freelancer convertion: Wrong mesh type?

I converted some models from Homeworld 1 to Freelancer (nothing special, the ordinary way). I hardpointed the model, coded it into the INI and started testing. The game started normally, but when I started a new game (with the ship I converted) it crashed.
FLSpit says: "WARNING: Failed to get start location."
The location wasn't the problem. I tried the same location with another ship and it worked fine.
I thought it was one of the texture names (it had a ~ in it) so I changed it and it didn't help.

Maybe someone here has also experienced this problem with Homeworld 1 ships?
I've attached the CMP, SUR (built with LS's tool) and MAT in a zip file that you can check it out.

Oh, almost forgot, the SUR is displayed grey in HardCMP, not white as usual. Does it have any relation to the problem?
Signature from »PolarBear«

SWAT_OP-R8R

Administrator

(12)

    Germany

Posts: 1,553

Activitypoints: 8,615

Date of registration: Oct 15th 2010

Reputation modifier: 14

Level: 45 [?]

Experience: 4,626,819

Next Level: 5,107,448

Thanks: 34

  • Send private message

member since 96 month member since 96 month member since 96 month member since 96 month member since 96 month member since 96 month member since 96 month member since 96 month

2

Friday, June 17th 2011, 5:03pm

"WARNING: Failed to get start location." is clearly not a ship related warning
it is result of using an OpenSP version and can get ignored

the color of the sur wireframe can also be ignored... its set to the material of the ship sometimes
thats just normal
Signature from »SWAT_OP-R8R«


(\__/)
(='.'=) This is Bunny. Copy and paste bunny into your
(" )_(" ) signature to help him gain world domination.
Only dead fish swim with the stream.
Diplomacy is the art of saying, "Nice doggie" while picking up a rock.

PolarBear

Gunnery Sergeant

(10)

  • "PolarBear" started this thread
  • Israel

Posts: 574

Activitypoints: 3,435

Date of registration: May 3rd 2011

Reputation modifier: 1

Level: 39 [?]

Experience: 1,595,383

Next Level: 1,757,916

Thanks: 4

  • Send private message

member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month

3

Friday, June 17th 2011, 6:45pm

So why does it crash with this specific ship model?
Signature from »PolarBear«

SWAT_OP-R8R

Administrator

(12)

    Germany

Posts: 1,553

Activitypoints: 8,615

Date of registration: Oct 15th 2010

Reputation modifier: 14

Level: 45 [?]

Experience: 4,626,819

Next Level: 5,107,448

Thanks: 34

  • Send private message

member since 96 month member since 96 month member since 96 month member since 96 month member since 96 month member since 96 month member since 96 month member since 96 month

4

Friday, June 17th 2011, 8:39pm

half a million possible reasons
-equipment related
-crc conflicts
-wrong hardpoint config
-material issues
-defect surs
-defect wireframes
-wrong typos in the inis

I cant really say from here.
Signature from »SWAT_OP-R8R«


(\__/)
(='.'=) This is Bunny. Copy and paste bunny into your
(" )_(" ) signature to help him gain world domination.
Only dead fish swim with the stream.
Diplomacy is the art of saying, "Nice doggie" while picking up a rock.

PolarBear

Gunnery Sergeant

(10)

  • "PolarBear" started this thread
  • Israel

Posts: 574

Activitypoints: 3,435

Date of registration: May 3rd 2011

Reputation modifier: 1

Level: 39 [?]

Experience: 1,595,383

Next Level: 1,757,916

Thanks: 4

  • Send private message

member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month

5

Saturday, June 18th 2011, 9:38am

I'm 100% sure its a mesh/texture problem, since I checked the rest and theyre all fine and working. I thought of a posibility that its a problem with my exporter. Will try to re-export 1st thing tomorrow.

EDIT: I tried to use them as NPCs and thats what FLSpit says: "WARNING:General: DA SYSTEM: trailing references" (I didn't re-export yet)
Signature from »PolarBear«

This post has been edited 1 times, last edit by "PolarBear" (Jun 18th 2011, 9:38am)


SWAT_OP-R8R

Administrator

(12)

    Germany

Posts: 1,553

Activitypoints: 8,615

Date of registration: Oct 15th 2010

Reputation modifier: 14

Level: 45 [?]

Experience: 4,626,819

Next Level: 5,107,448

Thanks: 34

  • Send private message

member since 96 month member since 96 month member since 96 month member since 96 month member since 96 month member since 96 month member since 96 month member since 96 month

6

Saturday, June 18th 2011, 9:47am

thats also a warning which doesnt have anything to do with ships
Signature from »SWAT_OP-R8R«


(\__/)
(='.'=) This is Bunny. Copy and paste bunny into your
(" )_(" ) signature to help him gain world domination.
Only dead fish swim with the stream.
Diplomacy is the art of saying, "Nice doggie" while picking up a rock.

PolarBear

Gunnery Sergeant

(10)

  • "PolarBear" started this thread
  • Israel

Posts: 574

Activitypoints: 3,435

Date of registration: May 3rd 2011

Reputation modifier: 1

Level: 39 [?]

Experience: 1,595,383

Next Level: 1,757,916

Thanks: 4

  • Send private message

member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month

7

Saturday, June 18th 2011, 1:00pm

I tried re-exporting, but its no use. Its like FLSpit doesn't say anything about this error, but it exists...
Signature from »PolarBear«

Social bookmarks

Legend:

Forum contains no new posts
Forum contains new posts
Forum is closed
Forum is an external link