You are not logged in.

polarbear

Gunnery Sergeant

(10)

  • "polarbear" started this thread
  • Israel

Posts: 574

Activitypoints: 3,435

Date of registration: May 3rd 2011

Reputation modifier: 1

Level: 39 [?]

Experience: 1,595,508

Next Level: 1,757,916

Thanks: 4

  • Send private message

member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month

1

Friday, August 8th 2014, 10:53am

Problem: new voice entry crash

I added a new system, and spliced a voice entry for specific voiced that will be refering to this system.

I added the new .wav file into the voice's .utf archive, under the hash of it's "msg_id_prefix" (gcs_refer_system_EW07; 0x83982148 ) and set a patrol to this jump hole.

Now, whenever I enter the system in which the jump hole is located, the game crashes. FLSpit says nothing about this hash.

Any help please?
Thanks.

Posts: 67

Activitypoints: 385

Date of registration: Apr 28th 2011

Reputation modifier: 2

Level: 28 [?]

Experience: 186,550

Next Level: 195,661

Thanks: 2

  • Send private message

member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month

2

Friday, August 8th 2014, 12:18pm

Is 3d sound off ? i have found in the past that crashes simular to this, at a jump gate/hole, system entry were caused by 3d sound

polarbear

Gunnery Sergeant

(10)

  • "polarbear" started this thread
  • Israel

Posts: 574

Activitypoints: 3,435

Date of registration: May 3rd 2011

Reputation modifier: 1

Level: 39 [?]

Experience: 1,595,508

Next Level: 1,757,916

Thanks: 4

  • Send private message

member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month

3

Friday, August 8th 2014, 12:31pm

3D sound is on, but if it only works when it's off then it's no use.
Point is, I replaced sound entries in the past and it worked with 3D sound. But when I added a new one, it crashes. maybe it's about the quality?

SWAT_OP-R8R

Administrator

(12)

    Germany

Posts: 1,553

Activitypoints: 8,615

Date of registration: Oct 15th 2010

Reputation modifier: 14

Level: 45 [?]

Experience: 4,627,157

Next Level: 5,107,448

Thanks: 34

  • Send private message

member since 96 month member since 96 month member since 96 month member since 96 month member since 96 month member since 96 month member since 96 month member since 96 month

4

Friday, August 8th 2014, 3:03pm

and you are sure that the patrol is working correctly?
sounds usually dont crash the clients (except for codec reasons but i would exclude that)
Signature from »SWAT_OP-R8R«


(\__/)
(='.'=) This is Bunny. Copy and paste bunny into your
(" )_(" ) signature to help him gain world domination.
Only dead fish swim with the stream.
Diplomacy is the art of saying, "Nice doggie" while picking up a rock.

polarbear

Gunnery Sergeant

(10)

  • "polarbear" started this thread
  • Israel

Posts: 574

Activitypoints: 3,435

Date of registration: May 3rd 2011

Reputation modifier: 1

Level: 39 [?]

Experience: 1,595,508

Next Level: 1,757,916

Thanks: 4

  • Send private message

member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month

5

Friday, August 8th 2014, 5:48pm

I triple-checked it, looks fine in all means of code.
You can check it if you want:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
[Zone]
nickname = Zone_St01_path_theorder14
pos = -5836, 0, 23785
rotate = 90, 17, 180
shape = CYLINDER
size = 750, 53070
sort = 99
toughness = 13
density = 5
repop_time = 30
max_battle_size = 4
pop_type = field_patrol
relief_time = 20
path_label = theorder_01, 1
usage = patrol
mission_eligible = false
faction_weight = fc_or_grp, 10
density_restriction = 1, patroller
density_restriction = 1, police_patroller
density_restriction = 1, pirate_patroller
density_restriction = 4, lawfuls
density_restriction = 4, unlawfuls
encounter = patrolp_assault, 13, 1.000000
faction = fc_or_grp, 1.000000

[Zone]
nickname = Zone_St01_path_theorder15
pos = -5836, 0, 23785
rotate = -90, -17, 0
shape = CYLINDER
size = 750, 53070
sort = 99
toughness = 13
density = 5
repop_time = 30
max_battle_size = 4
pop_type = field_patrol
relief_time = 20
path_label = theorder_01, 2
usage = patrol
mission_eligible = false
faction_weight = fc_or_grp, 10
density_restriction = 1, patroller
density_restriction = 1, police_patroller
density_restriction = 1, pirate_patroller
density_restriction = 4, lawfuls
density_restriction = 4, unlawfuls
encounter = patrolp_assault, 13, 1.000000
faction = fc_or_grp, 1.000000


Other patrols and zone populations work perfectly.

I'll try to add adoxa's mp3 codec fix, maybe it'll work.
EDIT: It didn't. I'll try to re-export the file from the editor.
EDIT: That didn't work either. I have no idea what's wrong.

This post has been edited 2 times, last edit by "polarbear" (Aug 8th 2014, 5:48pm)


polarbear

Gunnery Sergeant

(10)

  • "polarbear" started this thread
  • Israel

Posts: 574

Activitypoints: 3,435

Date of registration: May 3rd 2011

Reputation modifier: 1

Level: 39 [?]

Experience: 1,595,508

Next Level: 1,757,916

Thanks: 4

  • Send private message

member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month member since 84 month

6

Friday, August 8th 2014, 7:24pm

I mabaged to get it to work after adding the value to voices_space_male under "msg = gcs_refer_system_EW07-", changing the hash id also with the minus in the end. apparently the minus is important...
Sorry for wasting your time, and thanks for trying to help :)

leoybas

Apprentice

(10)

    Germany Spain

Posts: 2

Activitypoints: 10

Date of registration: Apr 1st 2014

Reputation modifier: 1

Level: 13 [?]

Experience: 3,432

Next Level: 4,033

  • Send private message

member since 48 month member since 48 month member since 48 month member since 48 month

7

Saturday, November 1st 2014, 9:15pm

Your not wasting time.. every issue and solution is good to know :P

Social bookmarks

Legend:

Forum contains no new posts
Forum contains new posts
Forum is closed
Forum is an external link